Hírek | Archívum | Fórum | IRC | Amiga | AmigaOS | FAQ | RSS

 - Fórumok - Regisztráció - Keresés - Statisztika - Szabályzat - Pegasos.hu fórum
forum.amigaspirit.hu / Újgenerációs hardver / Pegasos II
<< . 1 . 2 . 3 . 4 . 5 . 6 . >>
Szerző Üzenet
rachy
Tag

# Elküldve: 2009. Feb. 17. 22:48


Es mi a helyzet az AltiVec-el masolassal? Mert G4-en azt is be lehetne vetni. Bar valoszinuleg nem lesz akkora nagy kulonbseg (ha lesz egyaltalan), mint a longword es a double masolas kozott.

Cobra
Piros troll

# Elküldve: 2009. Feb. 17. 23:03


Szerk: egyebkent, SAM-en nem gyorsul veletlenul a dolog ettol a duplaszeles copy-tol?


Nem, csak pegan. Egesz konkretan amit a 440EP leirasaban lattam, abbol azt tudom kikvetkeztetni, hogy ez a chip a DMA-ra van kihegyezve, es pl. PCI burst-ot csak a DMA engine-je csinal, vagyis ott akkor gyorsulna, ha felprogramoznam a 440EP egyik DMA engine-jet es azzal irnam ki a PCI buszon, vagy a Radeonnal DMA-znam be busmastering modban. Szerintem ezutobbi A1-en es pegan is tovabb novelne a sebesseget.

rachy
Tag

# Elküldve: 2009. Feb. 18. 10:13


@cobra

Azt mar probaltad, hogy kozponti memoriabol blitteled valahogy, esetleg valahogy compositiont is bevonva a mokaba? Azt nem tudom, hogy segit-e es egyaltalan mennyi befolyasa van a mukodes sebessegere, de el tudom kepzelni, hogy DMA-val fetchelne a grafkartyara a rendszer kulonosebb korok futasa nelkul.

Cobra
Piros troll

# Elküldve: 2009. Feb. 18. 13:32


rachy: Ha olyan blitter muveletet vegzel, ahol a source adat RAM-ban van, es videoramba kell a vegeredmenynek kerulnie, akkor a P96 is nyilvan egy sajat belso copy rutint hasznal, hisz a videokartyak blittere csak a videoramon belul mukodik.

rachy
Tag

# Elküldve: 2009. Feb. 18. 16:58 - Szerkesztve: rachy


@cobra

Nem arra gondoltam, hanem arra, hogy az AGP huzza be. Mar ha kepes ilyesmire es le is van kodolva. Legjobb tudomasom szerint AGP-n az aperture size-on belul tud a kartya busmasteringgel DMA-zni a sajat memoriajaba a kozponti memoriabol, de lehet, hogy oriasit tevedek. (Valoszinuleg Artician nem fog menni ugy sem, talan a Marvel vackan, ha bibelodtek ilyennel. De mit ertek en ehhez ugye. )

Chain-Q
Divatamigás

# Elküldve: 2009. Feb. 18. 17:14


A Pegasos II-n levo AGP slot elektronikailag egy mezei 66Mhz-s PCI slot. Semmifele AGP magia, apperture size, sideband lofasz nincs rajta. Szoval ha PCI-on meg lehet csinalni, akkor megy. Egyebkent sajt.

Cobra
Piros troll

# Elküldve: 2009. Feb. 18. 18:37


rachy, ChainQ: PCI-on is mukodik a bus-mastering, elvileg PCI GART-ot hasznalva be tudod mappelni Radeon sajat address space-jebe a RAM-od egy reszet, amit a blitter _elmeletileg_ el tudna erni. Csak az ilyesmihez kell kulon tamogatas a radeon driverben is, meg a kernelben is (a kernelnek letre kell hoznia a szukseges GART table-t, stb.).

Lazi
Mr. AmiCon

# Elküldve: 2009. Ápr. 07. 23:07


Mivel ugy latom, itthon nem tudok Pega OS4.1-hez hozzajutni, ugy dontottem Acube-tol rendelek.

Van esetleg valaki, aki szinten fontolgat hasonlot, mert akkor erdemes lenne egyszerre megtenni?

Cobra
Piros troll

# Elküldve: 2009. Ápr. 08. 10:21


Lazi: irok DM-nek mailt hogy mivan... mar reg fent kene lennie a weboldalanak. Ha tole nem egy a dolog, akkor szervezunk egy kozos rendelest, felrakok hirt, stb. Igy jo?

Lazi
Mr. AmiCon

# Elküldve: 2009. Ápr. 08. 11:32


Ok, megvarom. Tudsz meg valakit, akinek kell?

Cobra
Piros troll

# Elküldve: 2009. Ápr. 08. 12:00


Lazi: volt egy szavazas rola, bal oldalon ha megnezed ott meglatod kiknek kell.

Lazi
Mr. AmiCon

# Elküldve: 2009. Ápr. 09. 01:24


Koszi, megneztem.

Hat ha tenyleg mindenki komolyan gondolta es meg nem vette meg, akkor mindenkeppen kozosen kellene.

Bar erre a mennyisegre mar akar DM is rabukhatna!

Cobra
Piros troll

# Elküldve: 2009. Ápr. 09. 09:19


Lazi: tegnap irtam neki mailt de eddig nincs valasz. Mennyi idot adjunk neki? :)

Lazi
Mr. AmiCon

# Elküldve: 2009. Ápr. 09. 15:13


Cobra: Tekintve, hogy mindket esetben hetekbe telik mire kezhez vehetjuk, ne sokat... hopp, le is jart :)

Most ugyis unnepnap jon, de a het kozepen lepjunk valamit.

Cobra
Piros troll

# Elküldve: 2009. Ápr. 09. 15:59 - Szerkesztve: Cobra


Lazi: Fogalmam sincs mi tortent DM-el, elnyelte a fold vagy mi? Mindenesetre amikor azt mondod MOST, akkor felrakok egy hirt a kozos rendeles szervezeserol. Akarod te szervezni? :)

Lazi
Mr. AmiCon

# Elküldve: 2009. Ápr. 15. 09:17


Cobra: azt mondom, MOST!

Van most akcio is a Relec-nel. http://tinyurl.com/c2o852

Szedjuk ossze a mennyiseget es hatha hozza tudunk meg jutni 99 euroert.
Tedd ki a hirt es egy uj topicban beszeljuk meg a reszleteket.

Lazi
Mr. AmiCon

# Elküldve: 2009. Máj. 04. 23:40


Rekord ido alatt megerkezett RELEC-tol a csomagom. A fizetessel tokoltem egy darabig, mert marha messze van am a bank, ugyhogy vegul apr. 30-an fizettem ki, amit globalis munkaszuneti nap kovetett, am ennek ellenere maj. 4.-en kezbe kaptam az OS4.1 pega lemezet.

Sajnalom, hogy nem lehetett hazai forrasbol megoldani, mindesetre azt hiszem ennel gyorsabban akkor se ment volna (sot).

A telepites gond nelkul lezajlott (MOS melle), jelenleg klonozom az A1 hd-jet.
Az elso elmenyt az 1Gb memoria okozta... Hu *** ez nagyon jo!

Cobra
Piros troll

# Elküldve: 2009. Máj. 05. 09:43


Lazi: ne felejtsd a hotfixeket letolteni.

Lazi
Mr. AmiCon

# Elküldve: 2009. Máj. 05. 10:53


Koszi a figyelmeztetest, termeszetesen az volt az elso.

Lazi
Mr. AmiCon

# Elküldve: 2009. Máj. 05. 23:14


Nagy gaz van! Rachy, you are my only help!

A program amivel a plottert hajtom, nem megy a pegan. (MOS alatt sem.)
Ha elinditom, a cputemp docky 100%-ra felugrik, a program nem indul. Snoopy egyetlen sort sem jelez. Debugbuffer warm reset utan ures (illetve az ujrainditas utan szokasos).
Ugyanezt produkalja az osszes Amos progim. (Nem chipset problema. A1-en mukodik.)

Tudom, hogy itt az ideje portolni a cuccot c-be, de most nem erek ra ezzel foglalkozni. Gondolom emulatort fixelni sem kisebb feladat, de hatha van valami otlet!

Chain-Q
Divatamigás

# Elküldve: 2009. Máj. 05. 23:19


M****OS alatt a debug log mit mond esetleg? Például ezzel tudod megnézni a tartalmát.

Cobra
Piros troll

# Elküldve: 2009. Máj. 06. 08:13


Lazi: szerintem ki kene venned a sok Articia workaroundot a plotter driveredbol es akkor tuti menni fog pegan :PPP

Lazi
Mr. AmiCon

# Elküldve: 2009. Máj. 06. 10:21


Ja, meg biztos azert nem megy a G4-en mert agyon optimalizaltam G3-ra. :-)

Egyenlore kuzdok Charlie kerdesevel. Ugy nez ki OS4 telepito valamit osszekavart OF-ben ami a MOS-nak nem teccik. Nincs radeon driver, valami 640x480-as "fake native" modban bootol.

Egyebkent Cobra ha raersz megnezhetned Sam alatt is: http://aminet.net/gfx/conv/dr_hpgl.lha

Probaltam Petunia nelkul is, ugyhogy erdekesnek talalom, hogy mindegyik 68k emulator kifekszik tole.

Cobra
Piros troll

# Elküldve: 2009. Máj. 06. 10:54


Lazi: este megnezem Sam-en es a pegamon is. Nalam a MOS-nak nem kell semmi kulonos az OF-ben, csak meg kell neki adni parameterben hogy honnan bootoljon (pl. nalam BD=MOS0: mert ugy hivjak a particiot amire a MOS-t felraktam), ha ezt nem adom meg neki akkor quark kiirasa utan nem csinal semmit.

Chain-Q
Divatamigás

# Elküldve: 2009. Máj. 06. 12:03


@Lazi:
Ugy nez ki OS4 telepito valamit osszekavart OF-ben ami a MOS-nak nem teccik. Nincs radeon driver, valami 640x480-as "fake native" modban bootol.

Ez marhasag. Ha nincs Radeon driver (vagy barmely tamogatott drivert nem tudja betolteni), nincs kep, megall a "Quark/OpenFirmware" szoveg utan. Ott valami mas zarlat lesz, peldaul monitort csereltel, ezert nem megy a DDC. Ket modszer van:

1., a bootmenuben megprobalhatod nagyobb felbontasba force-olni (Bootmenu boot parameter)

2., sokan csinaljak, koztuk en is, hogy letorlik (atnevezik) a MOSSYS:Libs/ddc.library-t (pl. ddc.library_disabled-re), ezutan kezzel belovik a modokat ahogy anno szerettek a System Prefsben es akkor minden megjeleniton ugyanazok a modok lesznek, nem probalja meg hiperokosan autodetektalni...

Cobra
Piros troll

# Elküldve: 2009. Máj. 06. 17:23


Lazi: Pegan itt nalam is csak 100% CPU es semmi nem tortenik, Sam-en megnyilik egy ures ablak "Plotter preview" cimmel, meg van vannak menuk, csak nincs mit betoltenem :)

Valld be, hogy anti-Pegasos kodot raktal bele csak elfelejtetted! :D

Lazi
Mr. AmiCon

# Elküldve: 2009. Máj. 07. 22:51


Charlie:
Nemtom mi lehetett, mert bar nem csinaltam semmit, most be tudtam allitani a megfelelo felbontast. Viszont minden boot-nal jon egy shell ablak a "can't create env: in ram" uzenettel. Amig ezt be nem zarom, addig az Ambient el sem indul.

A logtool-t felraktam, a MUI class-al egyutt, de meg se nyikkan. Amikor a progit inditom az eger megall aztan kalap-kabat, csak a hard reset megy.

Asszem ezert a kodert a Hyperion meg sokat fog nekem fizetni :)

Chain-Q
Divatamigás

# Elküldve: 2009. Máj. 08. 11:03


Hat a MUI classt felrakni kar volt, mert a 2.2-ben minden benne van hozza... Szoval azt szedd le. :) Csak 1.4-en kellett... Egyebkent szerintem valami nagyon csunya boot-device fuckup van nalad, szerintem a M****OS reszben az OS4 particiorol akar bootolni, vagy valami. Mast nem tudok elkepzelni, hogy mitol akadna szet az egesz a francba.

Egyebkent nalam is ez van, hogy szanaszetfagy az AMOS cucctol... "B" eset, hogy radugsz valami masik gepet sorosporton, aztan megnezet mit sir... Elsore amugy az jut eszembe, hogy biztos nem tul sok neki a RAM? :) Marmint, az uA1-edben csak 256MB van, a Pegaban meg gondolom 1GB neked is. Lehet h. az AMOS library kodja valami magiat vegez a cimekkel, ami keves rammal nem faj, sok rammal meg KABOOM... Ez legalabbis gyanus. :)

Cobra
Piros troll

# Elküldve: 2009. Máj. 08. 22:42 - Szerkesztve: Cobra


ChainQ: A bootdevice-os elmelet lehetseges, de ezt konnyen orvosolni lehet, egyszeruen meg kell nezni pl. MediaToolBox alatt, hogy hivjak azt a particiot amin a MOS van (en direkt MOS0:-ra neveztem itt hogy konnyu legyen), aztan OF-ben beirni hogy 'boot hd:<n> boot.img BD=<particionev>' akkor tuti jo helyrol fogja tolni a bootot.

Ha Lazinak 2x512MB memoriamodulja van, akkor szerintem konnyen ki lehet probalni hogy egyet kiszed, mert nekem pl. Sam-en 512MB van es azon mukodik jol ez a cucc.

Lazi
Mr. AmiCon

# Elküldve: 2009. Máj. 09. 00:12


A bootdevice kapcsan nem tudom mi lehetne rossz. Maskepp nem is tudom bootolni a MOS-t, mint boot hd:0 boot.img
Mivel eloszor a MOS lett telepitve, az az elso particion van. Az OS4 meg a negyediken.

Egyebkent van itt mas is. Az OS4.1-et ugy telepitettem a pegara, hogy az A1 sys: particiojanak masolatara upgradeltem. A tobbi particio is azonos device nevvel masolva lett. Mindemellett az Aladdin4D helyesen renderel a pegan, (csakugy mint MOS alatt) de hibasan szamol a uA1-en. Mivel a ket petunia kick modul azonos verzionak tunik nem ertem mibol jelentkezhet a kulonbseg.

A RAM redukciot kiprobalom amint tudom, aztan okosabbak leszunk.

<< . 1 . 2 . 3 . 4 . 5 . 6 . >>
forum.amigaspirit.hu / Újgenerációs hardver / Pegasos II
 
 

Powered by discussion forum software miniBB™ © 2001-2019