Hírek | Archívum | Fórum | IRC | Amiga | AmigaOS | FAQ | RSS

 - Fórumok - Regisztráció - Keresés - Statisztika - Szabályzat - Pegasos.hu fórum
forum.amigaspirit.hu / Classic AmigaOS / Szoftver problémák, megoldások, tanácsok ...
. 1 . 2 . 3 . 4 . 5 . 6 . 7 . 8 . 9 . 10 ... 38 . 39 . >>
Szerző Üzenet
dh1
Mr. DTP

# Elküldve: 2011. Jún. 01. 16:59


ECS A2000 ket mega chip rammal, KS3.1, WB3.1. Eddig 8 szinben hasznaltam HiRes Laced (Scandoubler/FF miatt nem jatszik, hogy lace ...). 16 szinben eleg tetu volt. MagicWB-s ikonok es paletta. Plusz NewIcons aktivalva (ertsd NewIcons is rendben megjelenik).

Cosmos uj graphics.library-javal azonban megtaltosodott a gui. Siman megy megfelelo sebesseggel HiRes Lace-ben is 16 szinnel.

Nade ... 8-rol 16 szinre valtas utan az osszes MagicWb-s ikon rozsaszinben jatszik ... van erre valami megoldas? Ugy remlik regrol, hogy volt valami ware erre. Talan a Full Palette nevu?

Valaki, valami okosat? :)

TCH
Tag

# Elküldve: 2011. Jún. 01. 18:48 - Szerkesztve: TCH


A ClickMeForColors állítja be jól a színeket.
Vagy manuális megoldás: WB 2.X-ből kiszeded a Prefs/Palette programot és azzal átállítod magadnak. T.i.: A WB 3.X Palettaprogramja csak az alsó 8 vagy 4 színt engedi szerkeszteni, míg a 2.X-é 16-ot. (BTW a WB2Palette programja elindításkor helyre is teszi a színeket.)
Másik manuális megoldás: aminet.net és szedsz palettaprogramot.
Ez az új graphics.library ez van 3.1-hez is? Vagy only 3.9 WB.

dh1
Mr. DTP

# Elküldve: 2011. Jún. 01. 18:54


Quoting: TCH
Ez az új graphics.library ez van 3.1-hez is? Vagy only 3.9 WB.


3.9-hez is van ...
de nem csak graphics, minden mas, ezek mar az uj 3.9.1-es KS reszei ... rohadt jo, A2000 feleledt tole! De AGA-n nagyobb a gyorsulas elvileg, bar nem volt meg lehetosegem kiprobalni!

http://eab.abime.net/showthread.php?t=51628&page=8

http://eab.abime.net/showthread.php?t=57950

http://eab.abime.net/showthread.php?t=57419

TCH
Tag

# Elküldve: 2011. Jún. 01. 18:57 - Szerkesztve: TCH


Akkor ezek az új libraryk jók a 3.1-es A500+-ba is?
SetPatch nem zavar be?

Sz*rk: Hát nálam semmit sem csinál. Kell valahogy szólni az Amigának, hogy töltse be?

amigarules
Tag
# Elküldve: 2011. Jún. 01. 22:21


Ha a 2000-est felpörgeti akkor az A500-at is fel kell nekije'...vagymi

TCH
Tag

# Elküldve: 2011. Jún. 01. 23:28


Hát nekem nem megy. :(

dh1
Mr. DTP

# Elküldve: 2011. Jún. 02. 08:31


TCH vegigcsinaltad azt amit ker?
Version paranccsal mi a verzioszama jelenleg a graphics.library-dnak?

Amugy igen, rezidensen be kell tolteni setpatch elott.
Ezen felul a Setpatch parancsot is spatcholni kell!!!!

Csinaljak egy reszletes leirast vagy megvarjatok a kovetkezos Amiga Maniat? :)

Nalam 666x4 x 16 szinben total hasznalhato lett, elotte meg szabalyosan lattam ahogy rajzolja az ikonokat, ablakokat.

TCH
Tag

# Elküldve: 2011. Jún. 02. 09:08


Nem csináltam semmit, csak bevágtam a libs:-be.
A verziószámot már tegnap megnéztem sysinfoval, az 40.24, tehát nem töltötte be, a ROM-ban lévő van használatban.

Részletes leírás az ráér a következő AM-ig, de ha azt elmondod, hogy mit írjak be a startup-ba, azt megköszönöm. :)

Az exec.library felrakásával milyen előnyök járnak?

dh1
Mr. DTP

# Elküldve: 2011. Jún. 02. 09:28


Aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa

Szerinted a graphics.library a libs-ben van?

Vajon miert az uj KS 3.9.1 resze???

Na vajon miert???

Igen, helyes a valasz! Merthogy a KS resze, tehat rezidensen fel kell tolni a ramba ...

Installation

- Use ROMSplit v1.0rc15 with an A500-A2000 Kickstart file v40.63 to extract the 'graphics.lib_40.24(OCS-ECS)'
- Download gpatch.lha (on Aminet)
- Open a Cli and use GPatch : 'gpatch graphics.lib_40.24(OCS-ECS) gfx_4025b3.gpch Libs:graphics.library_40.25b3'
- Rename SetPatch : 'Rename C:SetPatch C:SetPatch_ori'
- Use GPatch for getting SetPatch v44.39 : 'gpatch C:SetPatch_ori sp_4439.gpch C:SetPatch'
- Put LoadModule v40.11 into C:
- Update your StartUp-Sequence with 'LoadModule Libs:graphics.library_40.25b3' before SetPatch
- Reboot your computer
- To check, run on a cli : 'version full SetPatch' and 'version full graphics.library'

This beta is experimental

- The OCS/ECS is 100% ok, but some functions use now fastram (if installed) instead of chip, so maybe some games won't like that.
I'll certainly add a new option in the early-startup for keeping original routines
- The AGA/CD32 is OCS/ECS with only R_GetColorMap updated. More changes were made for the last gfx chipset ?


Know bugs

- On native screens, some glitchs when click on icons. Same with v40.24 ! My A1200 rev 2B ?

TCH
Tag

# Elküldve: 2011. Jún. 02. 10:18 - Szerkesztve: TCH


Tudom, hogy a KS része, írtam is, hogy a ROM-é van használatban. Csak megszokásból dobtam oda, hogy majd később lesz vele valami. Eddig sosem csináltam olyat, hogy kicseréltem egy ROM libraryt.

Kösz a quotet, hazaérek kipróbálom.

dh1
Mr. DTP

# Elküldve: 2011. Jún. 02. 11:25


Quoting: TCH
Kösz a quotet, hazaérek kipróbálom.


Ok! Szivesen. Megeri!

Mondjuk azt nem tettem hozza, hogy az A2000-ben egy 030/30 duborog :)

dh1
Mr. DTP

# Elküldve: 2011. Jún. 02. 11:26


Majd valamikor kiprobalom A600-on (A600, A1200 es A4000 letezik, hiszen ott alap az SCSI lib) az uj SCSI.LIBRARY-t is ... ilyen 300-600K-val teljesit jobban mint az alap ...

TCH
Tag

# Elküldve: 2011. Jún. 02. 12:00


A 030 nem para, az A500+-omban is az van. A 30 már gázabb, az enyim csak 14. De rohadjak meg, ha nem sikerül egyszer felturbózni. :P

scsi.library? Talán scsi.device, nem? :)
Az exec library előnyeire viszont kiváncsi lennék.

dh1
Mr. DTP

# Elküldve: 2011. Jún. 02. 14:00


Igen device ... kicsit ossze vok esve ... :(

dh1
Mr. DTP

# Elküldve: 2011. Jún. 02. 14:01


Az exec asszem csak 3.9-tol muxik ...
3.9-et meg valahogy GFX kartya nelkul es 8 mega fastrammal nem akarok az A2000-re eroltetni jelenleg ...

TCH
Tag

# Elküldve: 2011. Jún. 02. 14:24 - Szerkesztve: TCH


Jobbulást.

Hát én is csak akkor fogom használni ezt a micsodát, ha 100% kompatibilis a WB 3.1-el. Nem akarok 3.9-es WB-t felrakni.

dh1
Mr. DTP

# Elküldve: 2011. Jún. 02. 14:35


A graphics.lib az 100% kompatibilis.
Feher hollo ha hiba elojon ...
De a srac javitja ha elkuldod neki ...

TCH
Tag

# Elküldve: 2011. Jún. 02. 15:00


Na az akkor zsír. :)
És a 3.9.1-es kickrom? Az is az lesz? Vagy ahhoz már required a 3.9-es WB?

dh1
Mr. DTP

# Elküldve: 2011. Jún. 02. 15:54


Igen, az mar OS3.9.
Arra lesz kihegyezve.
68k ClassicOS-bol a csucs!

TCH
Tag

# Elküldve: 2011. Jún. 02. 16:06 - Szerkesztve: TCH


Én inkább maradok a 3.1-esnél.
Illetve, ami kompatibilis, azt átemelem.

dh1
Mr. DTP

# Elküldve: 2011. Jún. 02. 17:58


Ilyen fullra kezzel optimalizalnak mindent, hogy minel gyorsabb legyen.
KS-bol felismer szinte minden fontosabb videokartyat ...
Az osszes letezo gyorsitopacsker bele lesz integralva ...
Nem veletlenul lett 1 megas a KS3.9.1 ... 512-es ROM-ba nem fert bele sehogysem ...

dino
Kék troll

# Elküldve: 2011. Jún. 02. 18:51


Ooo, mintha azt olvastam volna valahol, hogy a 3.9 kickstartba van valami CD filesystem alapbol. Tudsz errol valamit mondani dh1?

TCH
Tag

# Elküldve: 2011. Jún. 03. 14:55


A LoadModule-t, meg a gpatchot felraktam. Viszont ehhez a SplitROM-hoz MUI kell.
Hogyan tudom még kirántani a kickstartból a graphics.library-t?

TCH
Tag

# Elküldve: 2011. Jún. 05. 18:15


Valaki, valami tipp esetleg?

dh1
Mr. DTP

# Elküldve: 2011. Jún. 05. 21:36 - Szerkesztve: dh1


Mi a baj a MUI-val?
Tudomasom szerint nincs mas progi erre ...
Legalabbis nem ismerek es ahogy nezem Aminet sem ...
Amugy megkersz valakit :)
En elkuldenem, de nem vagyok Amiga kozelben hetekig ... :(

TCH
Tag

# Elküldve: 2011. Jún. 05. 22:46


Semmi, csak az, hogy nix keyfile hozzá. :P
Megkérnék én bárkit, csak ahogy nézem, a ROMok között még azonos verzió és kibocsájtás esetén is lehetnek különbségek, vagyis a sajátomból kell kiszednem mindenképpen, a biztonság kedvéért.

Mi történt veled amúgy? Remélem nem komoly.

tassika
Tag

# Elküldve: 2011. Jún. 06. 04:19


Quoting: TCH
Semmi, csak az, hogy nix keyfile hozzá. :P


Nem kell a MUI-hoz keyfile. Tudod anélkül is használni. Csak annyi, hogy keyfile nélkül nem tudod agyon csicsázni, csak bizonyos alapbeállításokat enged módosítani.

tassika
Tag

# Elküldve: 2011. Jún. 06. 04:21


Quoting: tassika
Mi történt veled amúgy? Remélem nem komoly.


Igen, dh1 mi van veled!

dh1
Mr. DTP

# Elküldve: 2011. Jún. 06. 09:07


4 eve kuzdok kulonfele rosszulletekkel.
A labam zizeg, a hatam faj es felsugaroz a tarkomba, szedules, gyengeseg ...
Nem tudjak mi az oka ...
Negy eve orvosrol orvosra ...
Persze mindenhol azt mondjak, hogy fogyjak le ... csak hat amikor kezdodott en 2-3 szammal kisebb voltam ... ez mar annak a folyomanya ... marmint az elhizas. Regen jartam futni, meg kondizni minden nap ... Cobra meg emlekszik a gladiatoros idoszakomra ...
Aztan a "parom" most teljesen kicsinalt 6 ev utan ... vagyis nem is tudom, hogy nem emiatt a 6 ev miatt vagyok-e ilyen beteges. Nem kicsit kikeszultem ... :(

De az AM kovetkezo szamat meg megcsinalom nyugi ha ezert aggodtok! :P

TCH
Tag

# Elküldve: 2011. Jún. 06. 09:15


Hát ez gáz, Amigo. Jobbulást.

Miattad aggódunk, az AM megvár.

. 1 . 2 . 3 . 4 . 5 . 6 . 7 . 8 . 9 . 10 ... 38 . 39 . >>
forum.amigaspirit.hu / Classic AmigaOS / Szoftver problémák, megoldások, tanácsok ...
 
 

Powered by PHP forum software miniBB™ © 2001-2017