Hírek | Archívum | Fórum | IRC | Amiga | AmigaOS | FAQ | RSS

 - Fórumok - Keresés - Statisztika - Szabályzat - Pegasos.hu fórum
forum.amigaspirit.hu / MorphOS / MorphOS 3.3
<< . 1 . 2 . 3 . 4 . 5 . 6 . 7 . 8 . 9 . >>
Szerző Üzenet
Chain-Q
Divatamigás

# Elküldve: 2013. Nov. 22. 13:51


Úgy keress, hogy a Linuxos Atheros driver miket támogat... Mert nagyjából ugyanaz a driver (a Neil Cafferkey-féle drivert integrálták, ami OS4-re is van, meg AROS-ra is és alapvetően Linux port)...

BSzili
Tag

# Elküldve: 2013. Nov. 22. 22:08


Neil valami olyasmit írt a MorphZone-on, hogy a MadWifi által támogatott 11g-s kártyákkal érdemes próbálkozni.

dh1
Mr. DTP

# Elküldve: 2013. Nov. 23. 09:00


Quoting: BSzili
Neil valami olyasmit írt a MorphZone-on, hogy a MadWifi által támogatott 11g-s kártyákkal érdemes próbálkozni.


Akkor ez alapjan a megrendelt WG311T jo lesz ... :)

dh1
Mr. DTP

# Elküldve: 2013. Nov. 27. 12:33 - Szerkesztve: dh1


Van egy gondom ...
Ha elinditom a gepet (PB), nem megy a net ... (WiFi)
De az OWB "couldn't resolve host" hibauzenettel semmit nem hoz be, pingelni ugyancsak nem lehet.
Ha belepek a Rendszerbeallitasok/Network-be, ott minden jo, latja a wifit stb.
Ranezesre minden rendben.
Statikus IP beallitasok vannak.
Ha barmit valtoztatok es elmentem, de akar csak atkapcsolok Statikusrol Dinamikusra, majd vissza (tehat semmit sem allitok at) es mentek, azonnal minden megjavul ...
Restart utan megint nem megy ...
Fenti muveletet ismetelve ismet megy ...
WTF? Idegbajt kapok ...

Jah es hol lehet kikapcsolni azt az ominozus fileok felett feljovo buborekot, mert agyhugykovet kapok mar tole ... :)

dino
Kék troll

# Elküldve: 2013. Nov. 27. 13:21


Quoting: dh1
fileok felett feljovo buborekot, mert agyhugykovet kapok mar tole ...


Szerintem nem lehet meg most sem, legalabbis nekem nem sikerult, hiaba mondom neki, hogy "kerem kacsojja le" nem kapcsojja, csak azert sem... wifim nincs MorphOs en, szal ez reszemrol passz.

dekanyz
Tag

# Elküldve: 2013. Nov. 27. 13:58 - Szerkesztve: dekanyz


A Wifi-s problema nalam is meg van, de nem mindig.
Mostanaban alig hasznalom a WIFI-t, ugyhogy nem kiserleteztem ezzel.
Remelem nem a kartyankat nem szereti!

dh1
Mr. DTP

# Elküldve: 2013. Nov. 27. 14:07 - Szerkesztve: dh1


Nem, biztos vagyok benne, hogy szoftver problema ... merthogy nekem a Chrysalis install ota csinalja ...
Most fogtam legyaktam ez egeszet es csak egy sima MOS3.3 van fent es nem jelentkezik a hiba ... tehat valami akad valamivel ... de nem tudom mi ...

10-bol 10x mukodik sima 3.3 alatt ... most teszteltem ...

megyek tovabb a hibakeresesben

Chain-Q
Divatamigás

# Elküldve: 2013. Nov. 27. 14:26 - Szerkesztve: charlie


@dh1:
De az OWB "couldn't resolve host" hibauzenettel semmit nem hoz be, pingelni ugyancsak nem lehet.

Amíg böngésző hibaüzenetet fosol nekem ide hálózati konfigurációs problémára, addig a válaszom: PEBKAC. :) Mint anyám, mikor Skypeon közölte, hogy "nem működik a számítógép" mert az Internyet Expókert eltérítette valami bugware amit fosbúkról szedett le... Komolyan... Szakmabeli vagy, kapd már össze magad!

Nekem mindig megy a WiFi, legfeljebb várni kell egy kicsit néha, amíg a TCP/IP stack összevakarja magát. Amúgy általános NetStack probléma, hogy ha fos a DHCP szervered (olcsó hulladék routerek FTW), akkor megakadhat a konfigurációs folyamat és úgy marad, de ez nem szokott WiFi specifikus lenni...

De akkor leírnám a diagnózis helyes módját: nyitsz egy shellt (Igen. Nyitsz egy shellt, or SFTU. Alap hotkey hozzá: jobbCommand-N)

Két parancs a "trükk". Mindkettő minimum AmigaOS 2.0 és AmiTCP 1.0 óta létezik, tehát igencsak MorphOS specifikus, tényleg:
1., "status"
- ez kilistázza a futó shell processzeket. Ha a listában látsz olyat, hogy "netconfig", akkor a konfigurációs folyamat még tart. Vagyis a netconfig küzd a bugware DHCP szervereddel...

2., "ifconfig"
- ez kilistázza a bekonfigurált hálózati interfészeket. Itt látnod kell a wl0 interfészt, amint konfigolódik (0.0.0.0 a hozzárendelt IP) vagy már bekonfigurálódott (van hozzá valami IP, ami nem 0.0.0.0).

Amennyiben a "netconfig" nevű processz a status parancs kimenetében már nem látható, de az interfészhez még mindig 0.0.0.0 tartozik, akkor a konfigurációs folyamat elhalt, ez esetben a "netconfig autoconfig" parancs kiadásával újra játszhat. (Figyelem, több netconfig parancsot ne indíts el párhuzamosan, mert rebútba torkollik... :)

További tipp, hogy ha már van a wl0 interfésznek érvényes IP-je, de továbbra sem működik a névfeloldás, akkor a DHCP szervered bitfost küldött névszerver konfiguráció helyett. Ennek tesztelésére ajánlom az amigaspirit.hu pingelését IP alapján, mely IP: 193.224.143.38. Állandó áthidaló megoldásként ajánlom pl. a Google névszerverének (8.8.8.8) bevésését a megfelelő konfigurációs mezőbe a Prefs-ben.

A MorphOS 3.4-ben egyébként további netconfig/netstack és egyéb környező fejlesztések történtek. Nem ígér senki tökéletességet, de a jó irányba halad...

Jah es hol lehet kikapcsolni azt az ominozus fileok felett feljovo buborekot, mert agyhugykovet kapok mar tole ... :)

Inkább tegyél a gépre OS4-et, nem való neked a MorphOS... Err, wait... :P

Chain-Q
Divatamigás

# Elküldve: 2013. Nov. 27. 14:34


@dh1:
Nem, biztos vagyok benne, hogy szoftver problema ... merthogy nekem a Chrysalis install ota csinalja ...

Csak mondom, hogy a Chrysalis pack teljesen 3rd party cucc, egy igen lelkes user csinálja, de mivel misztikus hibákat (lásd fent) okoz, ezért általában az első kérdés hogy próbáld meg nélküle... Hivatalosan a Chrysalis packkal súlyosbított MorphOS-hez nincs support, mert messze túlmegy azon, hogy csak egy szimpla felhasználói programcsomag lenne, konkrétan minden szart felrak, ami kitudja hova pancsol bele... A fejlesztők közül senki sem használja...

dh1
Mr. DTP

# Elküldve: 2013. Nov. 27. 14:34 - Szerkesztve: dh1


Hat jobb is az OS4 ... ez most mar bizton allithatom ... :P

Nincs mirol mas bugreportot fosni mint ami van ...
Ha hiszed ha nem en is neztem ezeket, megsem lettem okosabb ...

Ezert fordultam ide, bar ne tettem volna ... mert itt csak buta lehetsz az okosok mellett ... :P :D

Pont az volt a fura, hogy lathatoan minden rendben van de nem megy a net ... MOS3.3 alatt nincs baj ... Chyrisallis install utan jott be ez ... de mint latjuk mas kollegaknak is van ilyen gondjuk ... igaz ok eddig nem vertek nagydobra :)

Szal nem csak en vagyok a bena :)

MOS ... kicsit betanak tunik meg :D

Azert koszi a helpet! :)

dh1
Mr. DTP

# Elküldve: 2013. Nov. 27. 14:35 - Szerkesztve: dh1


Quoting: charlie
Chrysalis pack teljesen 3rd party cucc


nem vagyunk hulyek ... tudjuk :)

ettol meg jo cucc ... en meg azert is kideritem mi a bug benne, hogy mas ne szopjon vele ... szabad? :)

meg mielott ... nem a szopasra kertem engedelyt :)

dh1
Mr. DTP

# Elküldve: 2013. Nov. 27. 14:52


most megy ... erdekes, majd figyelem mi okozhatta, koszi a helpeket!

Chain-Q
Divatamigás

# Elküldve: 2013. Nov. 27. 15:02 - Szerkesztve: charlie


@dh1:
Közben azon gondolkodtam, hogy volt-e valaha tesztelve a static IP vs. WiFi kombó... :) És hogy mi okozhat ilyesmit... Pl. mi van akkor, ha valami ware elkezdi egyből tolni a már bekonfigurált hálózatot (mivel nem kell hozzá DHCP ez hamar megtörténik) - pl. a Grunch nekiáll frissítéseket ellenőrizni - de a WirelessManager még nem dudálta össze magát a WiFi hotspottal...

De tényleg, minek használsz statikus IP-t WiFivel? :)

dino
Kék troll

# Elküldve: 2013. Nov. 27. 15:03


Egyebkent mar elsore AmiConon sem mukodott, mikor a geped melle ultem.
Emlekszel? Majd egyszercsak lett net.

dh1
Mr. DTP

# Elküldve: 2013. Nov. 27. 15:24


Quoting: dino
Egyebkent mar elsore AmiConon sem mukodott, mikor a geped melle ultem.


Mert at kellett allni Lazi WiFi-jere :)
Ott nem volt semmi problema.

Quoting: charlie
Közben azon gondolkodtam, hogy volt-e valaha tesztelve a static IP vs. WiFi kombó...


azert static, mert tobb wifi eszkoz is van es volt mar, hogy DHCP eseten ugyan az az IP lett kiosztva ... igy meg fix minden ...

amugy most megy tokeletesen, semmi mast nem csinaltam, mint a MOS3.3-at ujrahuztam, es ujbol felraktam a Chrysalist ... elotte is kb. ez volt, de hogy egy sima Save miert kellett ahhoz hogy menjen a WiFi elotte azt nem tudom ...

Teny, hogy meg ismerkedek a rendszerrel, szal barmi lehet, de nem tudok semmi galibarol amit en okoztam volna neki ... fura jelenseg volt ...

Chain-Q
Divatamigás

# Elküldve: 2013. Nov. 27. 15:42 - Szerkesztve: charlie


@dh1:
Save esetén újraindul a TCP/IP stack és újra lefut a netconfig is... Amúgy a hálózati stack indítása (s:network-startup) lefuttatása az IPrefs-ből történik, a boot folyamat második felével párhuzamosan (lásd az IPrefs indításának helyét a startup-sequence-ben, onnantól két szálon futnak a dolgok!). Ha az user-startupból vagy a WBStartupból elindult valami ami turná a félig bekonfigolt hálózatot, az simán megboríthatta az egészet.

Amit aztán egy kézi save meggyógyított, az IP stack újraindításával. Most simán lehet hogy annyi történt, hogy ha minden újrahúztál, akkor a fájlrendszeren más sorrendben vannak a dolgok -> gyorsabb vagy lassabb egy egész picit a boot és ez már elég ahhoz hogy a probléma ne álljon elő... :)

Az efféle misztikus race conditionöket mindig a legviccesebb debugolni...

ratman
Kék troll

# Elküldve: 2013. Nov. 27. 15:58


@dh1: "azert static, mert tobb wifi eszkoz is van es volt mar, hogy DHCP eseten ugyan az az IP lett kiosztva ... igy meg fix minden .."

Akkor ott nagyobb baj van, ilyesmi normálisan működő DHCP esetén nem fordulhat elő.... :/

Chain-Q
Divatamigás

# Elküldve: 2013. Nov. 27. 16:19


@ratman:
Dehogynem. Gondolom az van, hogy több WiFi AP van, mindegyiken aktív DHCP szerverrel, és aztán az egész shebang össze van bridge-elve, vagy ugyanez pepitában, ha a WiFi és a LAN össze van bridge-elve és a DHCP szerver aktív a LAN routeren meg a WiFi AP-n is... :)

ratman
Kék troll

# Elküldve: 2013. Nov. 27. 16:24


Chain-Q: Na, ez a nem normális működés. Egy collision domainben csak egyetlen egy DHCP szerver lehet, ha jót akarsz. Lehet több is, de az már inkább mazochizmus. :D

... és akkor még arról a vicces dologról még nem is beszéltem, amikor a dhcp szerver nem ugyanabban a hálózati szegmensben van, csak van neki segítője, de a címeket ő osztja. :)

Chain-Q
Divatamigás

# Elküldve: 2013. Nov. 27. 16:30


@ratman:
Najó de te nagy hálózatokat üzemeltetsz, én meg arról a valószínű amigás user esetről beszélek, mikor az amigás user megveszi a hálózati eszközt, feldugja otthon, kattint kettőt valami webinterfészen, a két cucc mit sem tud egymásról, az egész összebugzik, aztán meg user anyáz és bedrótoz mindent kézzel mert ez a "büdös pécés szar nem működik, bezzeg az autoconfig az amigában az mindig!". :)

ratman
Kék troll

# Elküldve: 2013. Nov. 27. 16:40


@Chain-Q: nos, "azért, mert a kiskacsa nem tud úszni, még nem a víz a hülye" :D

Egyébként igen, ez a valószínűsíthető eset, sajnos a technológia és a technológiát használók tudásszintje nem egyformán növekszik.

Mondok egy példát (r-1-es user szintjére megyek le).

Androidos telefonon van ilyen menüpont, hogy "Repülő üzemmód". Bekapcsoltam, elengedtem és leesett a picsába. Mekkora szar már! :D

dh1
Mr. DTP

# Elküldve: 2013. Nov. 27. 19:24 - Szerkesztve: dh1


Meg mielott itt megdicsoulnetek magatoktol ... :D

Siman egy WiFi router eseten szamtalanszor elofordult minden wifi eszkozommel DHCP eseten, hogy nemely eszkoz bekapcsolasakor IP utkozesre hivatkozva nem mukodott ez vagy az ... foleg winfosos eszkozok panaszkodtak erre ...

A jelenlegi rendszerem valoban bridge-elve mukodik, de a staticra valo atteresem meg ezelott volt, amikor csak egy router volt itthon.

Mindezek mellett en szeretem tudni, hogy melyik IP-n melyik cuccom van.

A MOS reinstall es Chrysalis reinstall ota nincs jelen a bug ... ez van ... mondjuk megjegyzem, hogy a PB-n nincs ket egyforma boot MOS alatt ... ami eleg erdekes es felelmetes is valahol ...

En nem vagyok halozatai szakember. A megvasarolt termekeket a feature listajuknak megfeleloen hasznalom, sem tobbet, sem kevesebbet nem varok el toluk!

ratman
Kék troll

# Elküldve: 2013. Nov. 27. 19:44


@dh1: És hallottál már a rosszról, a gonosz statikus dhcp-ről? Kábé a bármelyik szappantartó tudja. Egyik oldalra beírod a doboz mac címét, a másikra meg a címet. Voila. Egyúttal ellenőrízheted, hogy melyik doboz a dhcp szerver is. :D

dh1
Mr. DTP

# Elküldve: 2013. Nov. 27. 19:56


Hallottam! De nekem full static kell, punktum :P

Chain-Q
Divatamigás

# Elküldve: 2013. Nov. 27. 19:58


Vadász, vadász... :)

dh1
Mr. DTP

# Elküldve: 2013. Nov. 27. 20:09


:)

siz
Tag

# Elküldve: 2013. Nov. 27. 20:37


Ilyen IP ütközés DHCP-vel akkor lehet, ha a lease-time-on belül újraindul random() [(c) by Charlie] a DHCP szerver és elfelejti, hogy kinek mit osztott ki. Vagy amit ratman is mondott: több DHCP szerver van és fogalmuk sincs, hogy ki, mit osztott. Bár ez is megoldható azzal, hogy különböző tartományokat adunk nekik a subneten belül a default (általában) 100-200 közötti helyett.

siz
Tag

# Elküldve: 2013. Nov. 27. 20:39


Quoting: charlie
Vadász, vadász... :)

:D ezen most nagyon nagyot röhögtem :D

dh1
Mr. DTP

# Elküldve: 2013. Nov. 27. 20:39


Ezt tudja egy Belkin vagy egy TP-Link router ...

ratman
Kék troll

# Elküldve: 2013. Nov. 27. 20:45


Pedig, tudja, csak be kell állítani. :)

<< . 1 . 2 . 3 . 4 . 5 . 6 . 7 . 8 . 9 . >>
forum.amigaspirit.hu / MorphOS / MorphOS 3.3
 
 

Powered by discussion forum software miniBB™ © 2001-2023